re = /(?:.*?(@\S*))|(.*)/i
str = 'blah blah blah @abc blah @bcd blah blah
test@ibe @i slkjhk idsufyiu @uh '
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result