const regex = /(?:.*?(@\S*))|(.*)/ig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:.*?(@\\S*))|(.*)', 'ig')
const str = `blah blah blah @abc blah @bcd blah blah
test@ibe @i slkjhk idsufyiu @uh `;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);