$re = '/(?:.*?(@\S*))|(.*)/i';
$str = 'blah blah blah @abc blah @bcd blah blah
test@ibe @i slkjhk idsufyiu @uh ';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;