import Foundation
let pattern = #"(?:.*?(@\S*))|(.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
blah blah blah @abc blah @bcd blah blah
test@ibe @i slkjhk idsufyiu @uh
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)