#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:QSPR )?TEST RESULTS:.+$"
Local $sString = "QSPR TEST RESULTS:<any text containing letters/alphabets/specialcharacters but not empty>" & @CRLF & _
"TEST RESULTS:<any text containing letters/alphabets/specialcharacters but not empty>" & @CRLF & _
"" & @CRLF & _
"---" & @CRLF & _
"this line won't match" & @CRLF & _
"---"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")