using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:QSPR )?TEST RESULTS:.+$";
string input = @"QSPR TEST RESULTS:<any text containing letters/alphabets/specialcharacters but not empty>
TEST RESULTS:<any text containing letters/alphabets/specialcharacters but not empty>
---
this line won't match
---";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}