$re = '/^(?:QSPR )?TEST RESULTS:.+$/m';
$str = 'QSPR TEST RESULTS:<any text containing letters/alphabets/specialcharacters but not empty>
TEST RESULTS:<any text containing letters/alphabets/specialcharacters but not empty>
---
this line won\'t match
---';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);