// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:QSPR )?TEST RESULTS:.+$").unwrap();
let string = "QSPR TEST RESULTS:<any text containing letters/alphabets/specialcharacters but not empty>
TEST RESULTS:<any text containing letters/alphabets/specialcharacters but not empty>
---
this line won't match
---";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}