re = /^(?:QSPR )?TEST RESULTS:.+$/m
str = 'QSPR TEST RESULTS:<any text containing letters/alphabets/specialcharacters but not empty>
TEST RESULTS:<any text containing letters/alphabets/specialcharacters but not empty>
---
this line won\'t match
---'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end