const regex = /^(?:QSPR )?TEST RESULTS:.+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:QSPR )?TEST RESULTS:.+$', 'gm')
const str = `QSPR TEST RESULTS:<any text containing letters/alphabets/specialcharacters but not empty>
TEST RESULTS:<any text containing letters/alphabets/specialcharacters but not empty>
---
this line won't match
---`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}