import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(#)((?:[A-Fa-f0-9]{3}){1,2})$";
final String string = "#0F0F0F\n"
+ "rgba( 1234, 1001%, 25.46, .5)\n"
+ "hsl( 123,50%, 0.4)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}