// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(#)((?:[A-Fa-f0-9]{3}){1,2})$").unwrap();
let string = "#0F0F0F
rgba( 1234, 1001%, 25.46, .5)
hsl( 123,50%, 0.4)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}