use strict;
my $str = '#0F0F0F
rgba( 1234, 1001%, 25.46, .5)
hsl( 123,50%, 0.4)';
my $regex = qr/^(#)((?:[A-Fa-f0-9]{3}){1,2})$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}