$re = '/^(#)((?:[A-Fa-f0-9]{3}){1,2})$/m';
$str = '#0F0F0F
rgba( 1234, 1001%, 25.46, .5)
hsl( 123,50%, 0.4)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);