re = /^(#)((?:[A-Fa-f0-9]{3}){1,2})$/m
str = '#0F0F0F
rgba( 1234, 1001%, 25.46, .5)
hsl( 123,50%, 0.4)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end