const regex = /^(#)((?:[A-Fa-f0-9]{3}){1,2})$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(#)((?:[A-Fa-f0-9]{3}){1,2})$', 'gm')
const str = `#0F0F0F
rgba( 1234, 1001%, 25.46, .5)
hsl( 123,50%, 0.4)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}