re = /(?i)(\b|[¡¿])(?<uno>[^\s]+\s[^,]+),\s(\k<uno>)([?!]|\b)/m
str = '- Dios mÃo, ¡está aquÃ, está aquÃ!
- ¿Qué paso, qué paso?
- Me rehúso, me rehúso.'
subst = '$1$2$4'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result