import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\b(?=\\w)|\\B(?!\\w))\\(*\\b[CDEFGAB](?:b|bb)*(?:\\+|\\#{1,2}|dim|sus|maj|min|aug|[mM°0-9])*\\(?[\\d\\/]*\\)?(?:[CDEFGAB](?:b|bb)*(?:\\#{1,2}|dim|sus|maj|min|aug|[mM°0-9])*[\\d\\/]*)*\\)*(?:\\b(?<=\\w)|\\B(?<!\\w))";
final String string = "F#\n"
+ "Angel eyes,\n"
+ "G#m\n"
+ "Why won’t you let me apologise?\n"
+ "Foul";
final String subst = "<span class=\"_c\">$1</span>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}