import re
regex = re.compile(r"(?:\b(?=\w)|\B(?!\w))\(*\b[CDEFGAB](?:b|bb)*(?:\+|\#{1,2}|dim|sus|maj|min|aug|[mM°0-9])*\(?[\d\/]*\)?(?:[CDEFGAB](?:b|bb)*(?:\#{1,2}|dim|sus|maj|min|aug|[mM°0-9])*[\d\/]*)*\)*(?:\b(?<=\w)|\B(?<!\w))", flags=re.MULTILINE)
test_str = ("F#\n"
"Angel eyes,\n"
"G#m\n"
"Why won’t you let me apologise?\n"
"Foul")
subst = "<span class=\"_c\">$1</span>"
result = regex.sub(subst, test_str)
if result:
print(result)