use strict;
my $str = 'F#
Angel eyes,
G#m
Why won’t you let me apologise?
Foul';
my $regex = qr/(?:\b(?=\w)|\B(?!\w))\(*\b[CDEFGAB](?:b|bb)*(?:\+|\#{1,2}|dim|sus|maj|min|aug|[mM°0-9])*\(?[\d\/]*\)?(?:[CDEFGAB](?:b|bb)*(?:\#{1,2}|dim|sus|maj|min|aug|[mM°0-9])*[\d\/]*)*\)*(?:\b(?<=\w)|\B(?<!\w))/mp;
my $subst = '<span class="_c">$1</span>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";