const regex = /(?:\b(?=\w)|\B(?!\w))\(*\b[CDEFGAB](?:b|bb)*(?:\+|\#{1,2}|dim|sus|maj|min|aug|[mM°0-9])*\(?[\d\/]*\)?(?:[CDEFGAB](?:b|bb)*(?:\#{1,2}|dim|sus|maj|min|aug|[mM°0-9])*[\d\/]*)*\)*(?:\b(?<=\w)|\B(?<!\w))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\b(?=\\w)|\\B(?!\\w))\\(*\\b[CDEFGAB](?:b|bb)*(?:\\+|\\#{1,2}|dim|sus|maj|min|aug|[mM°0-9])*\\(?[\\d\\\/]*\\)?(?:[CDEFGAB](?:b|bb)*(?:\\#{1,2}|dim|sus|maj|min|aug|[mM°0-9])*[\\d\\\/]*)*\\)*(?:\\b(?<=\\w)|\\B(?<!\\w))', 'gm')
const str = `F#
Angel eyes,
G#m
Why won’t you let me apologise?
Foul`;
const subst = `<span class="_c">$1</span>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);