#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "^07"
Local $sString = "07720772093"
Local $sSubst = "+447"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)