$re = '/^07/';
$str = '07720772093';
$subst = "+447";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;