using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^07";
string substitution = @"+447";
string input = @"07720772093";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}