const regex = /^07/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^07', '')
const str = `07720772093`;
const subst = `+447`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);