use strict;
my $str = '07720772093';
my $regex = qr/^07/p;
my $subst = '+447';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";