import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.)+?\\1";
final String string = "Business Parks - Research business parks in the Reading area with conference capabilities\n\n"
+ "Green Park - expensive and no advertising allowed except via their newsletter\n\n"
+ "Arlington Business Park - no facility Thames Valley Science Park (TVSP) -\n\n"
+ "Sleep";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}