use strict;
my $str = 'Business Parks - Research business parks in the Reading area with conference capabilities
Green Park - expensive and no advertising allowed except via their newsletter
Arlington Business Park - no facility Thames Valley Science Park (TVSP) -
Sleep';
my $regex = qr/(.)+?\1/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";