re = /(.)+?\1/m
str = 'Business Parks - Research business parks in the Reading area with conference capabilities
Green Park - expensive and no advertising allowed except via their newsletter
Arlington Business Park - no facility Thames Valley Science Park (TVSP) -
Sleep'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result