using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[A-Z\d]{6}(?:(, ?| )(?:[A-Z\d]{6}\1)*[A-Z\d]{6} *)?$";
string input = @"KEPM39, JEMGH5, HEPM21
KEPM39 JEMGH5 HEPM21
KEPM39,JEMGH5,HEPM21
JEPM34, KEPM11
JEPM34, KEPM11
JEPM34
KEPM39, JEMGH5 HEPM21, HEGD44 ZZZZZZ
KEPM39, JEMGH5 HEPM21";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}