const regex = /^[A-Z\d]{6}(?:(, ?| )(?:[A-Z\d]{6}\1)*[A-Z\d]{6} *)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[A-Z\\d]{6}(?:(, ?| )(?:[A-Z\\d]{6}\\1)*[A-Z\\d]{6} *)?$', 'gm')
const str = `KEPM39, JEMGH5, HEPM21
KEPM39 JEMGH5 HEPM21
KEPM39,JEMGH5,HEPM21
JEPM34, KEPM11
JEPM34, KEPM11
JEPM34
KEPM39, JEMGH5 HEPM21, HEGD44 ZZZZZZ
KEPM39, JEMGH5 HEPM21`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}