import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[A-Z\\d]{6}(?:(, ?| )(?:[A-Z\\d]{6}\\1)*[A-Z\\d]{6} *)?$";
final String string = "KEPM39, JEMGH5, HEPM21\n"
+ "KEPM39 JEMGH5 HEPM21\n"
+ "KEPM39,JEMGH5,HEPM21\n"
+ "JEPM34, KEPM11 \n"
+ "JEPM34, KEPM11\n"
+ "JEPM34\n\n\n"
+ "KEPM39, JEMGH5 HEPM21, HEGD44 ZZZZZZ\n"
+ "KEPM39, JEMGH5 HEPM21";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}