import Foundation
let pattern = #"^[A-Z\d]{6}(?:(, ?| )(?:[A-Z\d]{6}\1)*[A-Z\d]{6} *)?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
KEPM39, JEMGH5, HEPM21
KEPM39 JEMGH5 HEPM21
KEPM39,JEMGH5,HEPM21
JEPM34, KEPM11
JEPM34, KEPM11
JEPM34
KEPM39, JEMGH5 HEPM21, HEGD44 ZZZZZZ
KEPM39, JEMGH5 HEPM21
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)