re = /^[A-Z\d]{6}(?:(, ?| )(?:[A-Z\d]{6}\1)*[A-Z\d]{6} *)?$/m
str = 'KEPM39, JEMGH5, HEPM21
KEPM39 JEMGH5 HEPM21
KEPM39,JEMGH5,HEPM21
JEPM34, KEPM11
JEPM34, KEPM11
JEPM34
KEPM39, JEMGH5 HEPM21, HEGD44 ZZZZZZ
KEPM39, JEMGH5 HEPM21'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end