# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\s(\s)?/$1/g;t' <<< "T E S T R E N T A L A K T I E B O L A G"