import Foundation
let pattern = #"\s(\s)?"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"T E S T R E N T A L A K T I E B O L A G"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)