use strict;
my $str = 'T E S T R E N T A L A K T I E B O L A G';
my $regex = qr/\s(\s)?/p;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";