import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([|][-])(\\s)(Feature)(\\s)(name)(\\s+)[:](\\s+)[\"'](\\s)(SLM_Pool)(\\)s[\"'](\\s+)([|][-])(\\s)(Feature)(\\s)(version)(\\s+)[:](\\s+)[\"'][\"'](\\s+)([|][-])(\\s)(License)(\\s)(type)(\\s+)[:](\\s+)[\"']((\\w|\\|\\.|\\-|\\s)+)[\"'](\\s+)([|][-])(\\s)(License)(\\s)(Version)(\\s+)[:](\\s+)((\\w|\\|\\.|\\-|\\s)+)(\\s+)([|][-])(\\s)(Commuter)(\\s)(license)(\\s)(allowed)(\\s+)[:](\\s+)((\\w|\\|\\.|\\-|\\s)+)(\\s+)([|][-])(\\s)(Maximum)(\\s)(commuter)(\\s)(checkout)(\\s)(days)(\\s+)[:](\\s+)((\\w|\\|\\.|\\-|\\s)+)(\\s+)([|][-])(\\s)(Maximum)(\\s)(concurrent)(\\s)(user)\\(([^\\)]+)\\)(\\s+)[:](\\s+)((\\w|\\|\\.|\\-|\\s)+)(\\s+)([|][-])(\\s)(Unreserved)(\\s)(tokens)(\\s)(in)(\\s)(use)(\\s+)[:](\\s+)((\\w|\\|\\.|\\-|\\s)+)(\\s+)([|][-])(\\s)(Commuter)(\\s)(tokens)(\\s)(in)(\\s)(use)(\\s+)[:](\\s+)((\\w|\\|\\.|\\-|\\s)+)(\\s+)([|][-])(\\s)(Commuter)(\\s)(tokens)(\\s)(left)(\\s+)[:](\\s+)((\\w|\\|\\.|\\-|\\s)+)(\\s+)([|][-])(\\s)(Reserved)(\\s)(tokens)(\\s)(in)(\\s)(use)(\\s+)[:](\\s+)((\\w|\\|\\.|\\-|\\s)+)";
final String string = "@F0GGY945\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}