// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?mix)([|][-])(\s)(Feature)(\s)(name)(\s+)[:](\s+)["'](\s)(SLM_Pool)(\)s["'](\s+)([|][-])(\s)(Feature)(\s)(version)(\s+)[:](\s+)["']["'](\s+)([|][-])(\s)(License)(\s)(type)(\s+)[:](\s+)["']((\w|\|\.|\-|\s)+)["'](\s+)([|][-])(\s)(License)(\s)(Version)(\s+)[:](\s+)((\w|\|\.|\-|\s)+)(\s+)([|][-])(\s)(Commuter)(\s)(license)(\s)(allowed)(\s+)[:](\s+)((\w|\|\.|\-|\s)+)(\s+)([|][-])(\s)(Maximum)(\s)(commuter)(\s)(checkout)(\s)(days)(\s+)[:](\s+)((\w|\|\.|\-|\s)+)(\s+)([|][-])(\s)(Maximum)(\s)(concurrent)(\s)(user)\(([^\)]+)\)(\s+)[:](\s+)((\w|\|\.|\-|\s)+)(\s+)([|][-])(\s)(Unreserved)(\s)(tokens)(\s)(in)(\s)(use)(\s+)[:](\s+)((\w|\|\.|\-|\s)+)(\s+)([|][-])(\s)(Commuter)(\s)(tokens)(\s)(in)(\s)(use)(\s+)[:](\s+)((\w|\|\.|\-|\s)+)(\s+)([|][-])(\s)(Commuter)(\s)(tokens)(\s)(left)(\s+)[:](\s+)((\w|\|\.|\-|\s)+)(\s+)([|][-])(\s)(Reserved)(\s)(tokens)(\s)(in)(\s)(use)(\s+)[:](\s+)((\w|\|\.|\-|\s)+)"#).unwrap();
let string = "@F0GGY945
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}