import re
regex = re.compile(r"""
([|][-])(\s)(Feature)(\s)(name)(\s+)[:](\s+)["'](\s)(SLM_Pool)(\)s["'](\s+)([|][-])(\s)(Feature)(\s)(version)(\s+)[:](\s+)["']["'](\s+)([|][-])(\s)(License)(\s)(type)(\s+)[:](\s+)["']((\w|\|\.|\-|\s)+)["'](\s+)([|][-])(\s)(License)(\s)(Version)(\s+)[:](\s+)((\w|\|\.|\-|\s)+)(\s+)([|][-])(\s)(Commuter)(\s)(license)(\s)(allowed)(\s+)[:](\s+)((\w|\|\.|\-|\s)+)(\s+)([|][-])(\s)(Maximum)(\s)(commuter)(\s)(checkout)(\s)(days)(\s+)[:](\s+)((\w|\|\.|\-|\s)+)(\s+)([|][-])(\s)(Maximum)(\s)(concurrent)(\s)(user)\(([^\)]+)\)(\s+)[:](\s+)((\w|\|\.|\-|\s)+)(\s+)([|][-])(\s)(Unreserved)(\s)(tokens)(\s)(in)(\s)(use)(\s+)[:](\s+)((\w|\|\.|\-|\s)+)(\s+)([|][-])(\s)(Commuter)(\s)(tokens)(\s)(in)(\s)(use)(\s+)[:](\s+)((\w|\|\.|\-|\s)+)(\s+)([|][-])(\s)(Commuter)(\s)(tokens)(\s)(left)(\s+)[:](\s+)((\w|\|\.|\-|\s)+)(\s+)([|][-])(\s)(Reserved)(\s)(tokens)(\s)(in)(\s)(use)(\s+)[:](\s+)((\w|\|\.|\-|\s)+)
""", flags=re.MULTILINE | re.IGNORECASE | re.VERBOSE)
test_str = ("@F0GGY945\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")