re = /([|][-])(\s)(Feature)(\s)(name)(\s+)[:](\s+)["'](\s)(SLM_Pool)(\)s["'](\s+)([|][-])(\s)(Feature)(\s)(version)(\s+)[:](\s+)["']["'](\s+)([|][-])(\s)(License)(\s)(type)(\s+)[:](\s+)["']((\w|\|\.|\-|\s)+)["'](\s+)([|][-])(\s)(License)(\s)(Version)(\s+)[:](\s+)((\w|\|\.|\-|\s)+)(\s+)([|][-])(\s)(Commuter)(\s)(license)(\s)(allowed)(\s+)[:](\s+)((\w|\|\.|\-|\s)+)(\s+)([|][-])(\s)(Maximum)(\s)(commuter)(\s)(checkout)(\s)(days)(\s+)[:](\s+)((\w|\|\.|\-|\s)+)(\s+)([|][-])(\s)(Maximum)(\s)(concurrent)(\s)(user)\(([^\)]+)\)(\s+)[:](\s+)((\w|\|\.|\-|\s)+)(\s+)([|][-])(\s)(Unreserved)(\s)(tokens)(\s)(in)(\s)(use)(\s+)[:](\s+)((\w|\|\.|\-|\s)+)(\s+)([|][-])(\s)(Commuter)(\s)(tokens)(\s)(in)(\s)(use)(\s+)[:](\s+)((\w|\|\.|\-|\s)+)(\s+)([|][-])(\s)(Commuter)(\s)(tokens)(\s)(left)(\s+)[:](\s+)((\w|\|\.|\-|\s)+)(\s+)([|][-])(\s)(Reserved)(\s)(tokens)(\s)(in)(\s)(use)(\s+)[:](\s+)((\w|\|\.|\-|\s)+)/mix
str = '@F0GGY945
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end