import Foundation
let pattern = #"([|][-])(\s)(Feature)(\s)(name)(\s+)[:](\s+)["'](\s)(SLM_Pool)(\)s["'](\s+)([|][-])(\s)(Feature)(\s)(version)(\s+)[:](\s+)["']["'](\s+)([|][-])(\s)(License)(\s)(type)(\s+)[:](\s+)["']((\w|\|\.|\-|\s)+)["'](\s+)([|][-])(\s)(License)(\s)(Version)(\s+)[:](\s+)((\w|\|\.|\-|\s)+)(\s+)([|][-])(\s)(Commuter)(\s)(license)(\s)(allowed)(\s+)[:](\s+)((\w|\|\.|\-|\s)+)(\s+)([|][-])(\s)(Maximum)(\s)(commuter)(\s)(checkout)(\s)(days)(\s+)[:](\s+)((\w|\|\.|\-|\s)+)(\s+)([|][-])(\s)(Maximum)(\s)(concurrent)(\s)(user)\(([^\)]+)\)(\s+)[:](\s+)((\w|\|\.|\-|\s)+)(\s+)([|][-])(\s)(Unreserved)(\s)(tokens)(\s)(in)(\s)(use)(\s+)[:](\s+)((\w|\|\.|\-|\s)+)(\s+)([|][-])(\s)(Commuter)(\s)(tokens)(\s)(in)(\s)(use)(\s+)[:](\s+)((\w|\|\.|\-|\s)+)(\s+)([|][-])(\s)(Commuter)(\s)(tokens)(\s)(left)(\s+)[:](\s+)((\w|\|\.|\-|\s)+)(\s+)([|][-])(\s)(Reserved)(\s)(tokens)(\s)(in)(\s)(use)(\s+)[:](\s+)((\w|\|\.|\-|\s)+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive, .allowCommentsAndWhitespace])
let testString = #"""
@F0GGY945
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)