using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\{\\fsp-?((\d+)|(\d+\.\d+))\}";
string input = @"This pattern must match fsp tag with different values like {\fsp-0.667} or {\fsp-4} or {\fsp1.333}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}