const regex = /\{\\fsp-?((\d+)|(\d+\.\d+))\}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\{\\\\fsp-?((\\d+)|(\\d+\\.\\d+))\\}', 'gm')
const str = `This pattern must match fsp tag with different values like {\\fsp-0.667} or {\\fsp-4} or {\\fsp1.333}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}