re = /\{\\fsp-?((\d+)|(\d+\.\d+))\}/m
str = 'This pattern must match fsp tag with different values like {\\fsp-0.667} or {\\fsp-4} or {\\fsp1.333}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end