// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\{\\fsp-?((\d+)|(\d+\.\d+))\}").unwrap();
let string = "This pattern must match fsp tag with different values like {\\fsp-0.667} or {\\fsp-4} or {\\fsp1.333}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}