package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\{\\fsp-?((\d+)|(\d+\.\d+))\}`)
var str = `This pattern must match fsp tag with different values like {\fsp-0.667} or {\fsp-4} or {\fsp1.333}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}