#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)\sUsername\s'(?<username>[^']+)'.*\n.*\(/(?<ipaddress>[^\)]+)\).*Failed\sto\sverify\susername"
Local $sString = "[18:56:57] [User Authenticator #2/INFO]: Disconnecting *** (/185.204.1.184:58084): Failed to verify username!" & @CRLF & _
"[18:56:57] [User Authenticator #2/ERROR]: Username '***' tried to join with an invalid session" & @CRLF & _
"[18:56:57] [Server thread/INFO]: *** (/185.204.1.184:58084) lost connection: Failed to verify username!"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")