package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)\sUsername\s'(?<username>[^']+)'.*\n.*\(/(?<ipaddress>[^\)]+)\).*Failed\sto\sverify\susername`)
var str = `[18:56:57] [User Authenticator #2/INFO]: Disconnecting *** (/185.204.1.184:58084): Failed to verify username!
[18:56:57] [User Authenticator #2/ERROR]: Username '***' tried to join with an invalid session
[18:56:57] [Server thread/INFO]: *** (/185.204.1.184:58084) lost connection: Failed to verify username!`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}