$re = '/\sUsername\s\'(?<username>[^\']+)\'.*\n.*\(/(?<ipaddress>[^\)]+)\).*Failed\sto\sverify\susername/mi';
$str = '[18:56:57] [User Authenticator #2/INFO]: Disconnecting *** (/185.204.1.184:58084): Failed to verify username!
[18:56:57] [User Authenticator #2/ERROR]: Username \'***\' tried to join with an invalid session
[18:56:57] [Server thread/INFO]: *** (/185.204.1.184:58084) lost connection: Failed to verify username!';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);